In this Video-Tutorial we show you how you define and create a balcony with the 3D CAD house planning software cadvilla and how you import it into a project . Some of the functions in this video are only available in the product versions cadvilla professional and cadvilla professional plus.

The basic workflow:

  • In the first step we create in the 2D-view the floor panel of the balcony. Therefore we use the help of 2D guidelines (“2D & Layout” – “2D Guidelines”).
  • After we have defined the floor panel with the help of guidelines, we select “Construction” – “Create Surface Element” – “Insert with rectangle”. We create the rectangle along our guidelines and after it the surface element dialogue opens. Here we define at the point “Thickness” the thickness of the floor panel. At the point “Tiles” – “2D Display” we select for the Fill style “none”. After it we press “OK”. Please note that you enter the floor panel on the correct layer (activate the correct layer).
  • Now we create 2 section views for the floor panel. Therefore we select “View” – “New Section-View”. We define the area for the first section view (horizontal section axis) and after it the section view window opens. Now we define the second section view (vertical section axis) and after it we position the views side by side.
  • After it we open a new 3D-view, we deselect the environment in the 3D-view and we place the views with the function “horizontal” side by side. Now we can use the two side views and the 2D & 3D view at the same time.
  • Now we start to enter the mainstays of the balcony. Therefore we select in the first step the section view (section A-A) and we enter with the help of guidelines (“2D & Layout” – “2D Guidelines”) the dimensions of the mainstay in the section view. After we have entered the guidelines we can select “Construction” – “Sweep solid” – “Insert with polygon”. After it we make a left mouse click at the section view A-A. Now we define the sweep solid, therefore we make a right mouse click – “Properties”. In the properties we select “Sweep solid”. Here we define the width and the high and the reference point. After it we press “OK”. We enter the sweep solid in the section view A-A, after it we press the right mouse button – “Complete”.
  • To change the colour of a sweep solid we select the 3D-view – “3D Functions” – “Edit material”. We select the sweep solid and the material editor opens. Here we can define the texture, colour, transparency, etc . … . When we are finished we can press “OK”.
  • To bring the sweep solid into the correct position, we select the solid and we choose in the selection menu the function “Move with reference point” or we press the shortcut “r”. Of course we can also use the help of guidelines when we position the solid.
  • To create a multiple copy of the sweep solid, we select the sweep solid – right mouse button – “Multiple copy”. The Tool options window opens and we enter the number and the distance. The point “Clear distance” should be activated. After it we define the position and in the end we can press “OK”.
  • The definition of the railing is pretty much the same as the definition of the mainstays. Therefore we select again in the 2D-view the function “Sweep solid”, we define the properties of the sweep solid and we enter the sweep solid in the 2D-view. After it we define the height position of the railing in the side view with the help of guidelines and the function “Move with reference point” or the shortcut “r”. In the end we copy the railing with the function “Multiple copy”.
  • The definition of the handrail is also pretty much the same as the definition of the railing. Therefore we select again the function “Sweep solid”, we choose a surface in the 3D-view on which we will enter the sweep solid and after it we open the properties of the solid in the 2D view to define them. After it we enter the sweep solid in the 2D-view.
  • Of course we can choose a texture at the “Catalogue” – “Materials”, select it – press and hold the left mouse button and drag it on the sweep solid. To edit a texture we select “3D Functions” – “Edit Material”.
  • To save the balcony we select the 3D-view – open the menu – “Export” – “3D-Formats” – “3D object file”. We enter a name for the object and we confirm with “OK”. After it the window “Export project” appears, in this window we can define different export options. In the end we press “OK” and now the balcony is saved as a 3D object and it is possible to import it to other projects.
  • To import the balcony to another project, we select the “Catalogue” – “Open file”. We select the balcony and position it in our project. Of course we can use therefore the help of guidelines or of a section-view.

This post is also available in: German